iso to img os

Download the desired file
Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight)
Convert the .iso file to .img using the convert option of hdiutil:

hdiutil convert -format UDRW -o /path/to/target.img /path/to/source.iso

Note: OS X tends to put the .dmg ending on the output file automatically. Rename the file by typing:

mv /path/to/target.img.dmg /path/to/target.img

Run diskutil list to get the current list of devices
Insert your flash media

Run diskutil list again and determine the device node assigned to your flash media (e.g. /dev/disk2)

Run diskutil unmountDisk /dev/diskN (replace N with the disk number from the last command - in the previous example, N would be 2)

Execute sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m 
(replace /path/to/downloaded.img with the path where the image file is located;
for example, ./ubuntu.img or ./ubuntu.dmg).

Note: Using /dev/rdisk instead of /dev/disk may be faster.
Note: If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M.
Note: If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the 'Disk Utility.app' and unmount (don't eject) the drive.
Run diskutil eject /dev/diskN and remove your flash media when the command completes

Are there any code examples left?
Made with love
This website uses cookies to make IQCode work for you. By using this site, you agree to our cookie policy

Welcome Back!

Sign up to unlock all of IQCode features:
  • Test your skills and track progress
  • Engage in comprehensive interactive courses
  • Commit to daily skill-enhancing challenges
  • Solve practical, real-world issues
  • Share your insights and learnings
Create an account
Sign in
Recover lost password
Or log in with

Create a Free Account

Sign up to unlock all of IQCode features:
  • Test your skills and track progress
  • Engage in comprehensive interactive courses
  • Commit to daily skill-enhancing challenges
  • Solve practical, real-world issues
  • Share your insights and learnings
Create an account
Sign up
Or sign up with
By signing up, you agree to the Terms and Conditions and Privacy Policy. You also agree to receive product-related marketing emails from IQCode, which you can unsubscribe from at any time.
Creating a new code example
Code snippet title
Source